Skip to content

vue/no-deprecated-dollar-scopedslots-api โ€‹

disallow using deprecated $scopedSlots (in Vue.js 3.0.0+)

  • โš™๏ธ This rule is included in all of "plugin:vue/vue3-essential", "plugin:vue/vue3-strongly-recommended" and "plugin:vue/vue3-recommended".
  • ๐Ÿ”ง The --fix option on the command line can automatically fix some of the problems reported by this rule.

๐Ÿ“– Rule Details โ€‹

This rule reports use of deprecated $scopedSlots. (in Vue.js 3.0.0+).

See Migration Guide - Slots Unification for more details.

Now loading...

๐Ÿ”ง Options โ€‹

Nothing.

๐Ÿ“š Further Reading โ€‹

๐Ÿš€ Version โ€‹

This rule was introduced in eslint-plugin-vue v7.0.0

๐Ÿ” Implementation โ€‹