# vue/no-deprecated-events-api

disallow using deprecated events api (in Vue.js 3.0.0+)

  • ⚙️ This rule is included in all of "plugin:vue/vue3-essential", "plugin:vue/vue3-strongly-recommended" and "plugin:vue/vue3-recommended".

# 📖 Rule Details

This rule reports use of deprecated $on, $off $once api. (in Vue.js 3.0.0+).

See Migration Guide - Events API for more details.

<script> /* ✗ BAD */ export default { mounted () { this.$on('start', function(args) { console.log('start') }) this.$emit('start') } } </script>
Now loading...
<script> /* ✓ GOOD */ import mitt from 'mitt' const emitter = mitt() export default { mounted () { emitter.on('start', function(args) { console.log('start') }) emitter.emit('start') } } </script>
Now loading...

# 🔧 Options

Nothing.

# 📚 Further Reading

# 🔍 Implementation