Skip to content

vue/no-deprecated-functional-template

disallow using deprecated the functional template (in Vue.js 3.0.0+)

  • ⚙️ This rule is included in all of "plugin:vue/vue3-essential", "plugin:vue/vue3-strongly-recommended" and "plugin:vue/vue3-recommended".

📖 Rule Details

This rule reports deprecated the functional template (in Vue.js 3.0.0+).

See Migration Guide - Functional Components for more details.

Now loading...

🔧 Options

Nothing.

📚 Further Reading

🚀 Version

This rule was introduced in eslint-plugin-vue v7.0.0

🔍 Implementation